Vendor: Microsoft

Exam Code: 77-885

Exam Name: MOS: Microsoft Office Access 2010

Version: DEMO
QUESTION 1
You have a table named Projects created in Microsoft Office Access 2010. You are required to make some changes in the table's data. In which of the following views will you open the table to accomplish the task?

A. Datasheet view  
B. PivotChart view  
C. Design view  
D. PivotTable view

Answer: A

Explanation:
You should open the Projects table in the Datasheet view to make some changes in the table's data. The Datasheet view is the default view of a table. It is used to display and modify data of the table. When a table is opened in the Datasheet view, this view displays the table's data in columns (fields) and rows (records). The first row has column headings or field names. In order to open a table in the Datasheet view, a user should double-click on the table’s name or choose the Datasheet View option from the view list. The Datasheet view of a table is given below:

Answer: D and B are incorrect. In the PivotTable and PivotChart views, you can perform data analysis. Both of them are used to organize and summarize information into useful analysis presentations.
Answer: C is incorrect. In the Design view, you can view and modify the structure of a table.
QUESTION 2
Which of the following Report Layout tools is used to specify the color, width, and line style for the outline of the selected field of a report?

A. Arrange  
B. Design  
C. Page Setup  
D. Format

Answer: D
Explanation:
The Format tool is used to specify the color, width, and line style for the outline of the selected field of a report. It is also used to set font size, font style, and background image.

Answer: B is incorrect. The Design tool is used to apply themes, controls, and header/footer in a report.
Answer: A is incorrect. The Arrange tool is used to arrange the rows and columns in a report.  
Answer: C is incorrect. The Page Setup tool is used to set the page layout and page size of a report.

QUESTION 3
You have created a form named Details in Microsoft Office Access 2010. You want to add new elements, change the header/footer, and apply a new theme to the form. Which of the following tabs will you choose to accomplish the task?

A. Format  
B. Design  
C. Element  
D. Arrange

Answer: B
Explanation:
In order to accomplish the task, you should choose the Design tab lying in Form Layout Tools. You can add new elements, change the header/footer, and apply themes to the form by using the Design tab.
Answer: D is incorrect. The Arrange tab has various layout options. Answer: A is incorrect. The Format tab is used to change the color and font of text and the style of gridlines around the fields. It also includes a logo and various formatting options. Answer: C is incorrect. This tab is not displayed in Form Layout Tools.

QUESTION 4
Which of the following field properties allows you to enter a "" string in a field to indicate that there is no value for that field?

A. Allow Zero Length
B. Input Mask
C. Append Only
D. IME Mode

Answer: A
Explanation:
The Allow Zero Length property allows a user to enter a zero-length ("") string in a field to indicate that there is no value for that field.
Answer: C is incorrect. The Append Only property is mainly used for memo fields. When this property is set to 'Yes', it creates a field value history to add new text to the field. Answer: D is incorrect. The IME Mode property is related to East Asian languages. Answer: B is incorrect. The Input Mask property is used to specify that the field value should conform to the pattern set by the mask.

QUESTION 5
In which of the following views does the program window open when a user starts Microsoft Office Access 2010 without opening a database?

A. Backstage view
B. PivotTable view
C. Design view
D. PivotChart view

Answer: A
Explanation:
The program window opens in the Backstage view when a user starts Microsoft Office Access 2010 without opening a database. The Backstage view is a full-screen user interface model in which commands related to managing MS Access and Access database are arranged in the form of buttons and pages. The File tab in the upper-left corner of the program window displays the Backstage view. The Backstage view allows a user to create, save, and check hidden metadata or personal information. It also helps in discovering and using the features that are not related to the authoring features on the Ribbon.
Answer: D is incorrect. The PivotChart view of a table can be used to display the data of a table in the desired format using a graph. This view cannot be used to create or delete a field or modify its properties. The data can be filtered according to fields. When the PivotChart view is opened, a blank work area is displayed and the columns of the table are displayed in the Chart Field List window. A user has to drag and drop the fields to view the desired result. The PivotChart view uses an Office Chart Component and helps a user to create dynamic and interactive charts.

Answer: B is incorrect. The PivotTable view of a table can be used to display the data of a table in the desired format. This view cannot be used to create or delete a field or modify its properties. The data can be filtered according to fields. When the PivotTable view is opened, a blank work area is displayed and the columns of the table are displayed in the Pivot Table Field List window. A user has to drag and drop the fields to view the desired result.
Answer: C is incorrect. The Design view of a table displays its fields and datatypes. New fields can be added to the table and assigned to a datatype. A user cannot insert data in this view. The datatype of a field can be formatted and other table properties such as field size, validation rule, etc., can be set for the field.
QUESTION 6
Where can a user add any Access command as a button in Microsoft Access 2010?

A. Navigation Pane
B. Index
C. Quick Access Toolbar
D. Macro

Answer: C
Explanation:
The Quick Access Toolbar in MS Access 2010 is a customizable toolbar which is displayed in the title bar of the Database window. It has a set of commands or functions (save, undo/redo, and print) that are independent of the tab on the ribbon currently displayed in MS Access. The Quick Access Toolbar can be moved from one of the two possible locations. A user can add any Access command as a button to the Quick Access Toolbar.
Answer: A is incorrect. The Navigation Pane provides an interface for all database objects, such as tables, queries, forms, reports, macros, and modules. It is located along the left side of the Access screen. In the Navigation Pane, all items are organized into groups. It is also used to show or hide the database objects.
Answer: D is incorrect. In Microsoft Office Access 2010, a macro is a database object that defines the actions that are required for Access to perform as a result of a defined event. It is also used to open and execute queries, open tables, and print or view reports. A user can add simple conditions in macros to specify when actions are performed or skipped. Answer: B is incorrect. In Microsoft Office Access 2010, an index is a list of field values included in a table. It helps Access in finding and sorting records quickly. An index stores the record's location based on the columns that are part of the index. The indexed fields have unique values which make it more efficient and faster for Access to read and find a specific field value.

QUESTION 7
You have two tables named Customers and Orders created in Microsoft Office Access 2010. In Orders table, each order has a customer ID. You want to correspond it to a record in the Customers table. Which of the following will you use to accomplish the task? Each correct answer represents a complete solution. Choose all that apply.

A. Entity integrity
B. Domain integrity
C. Primary key
D. Foreign key

Answer: CD
Explanation:
In order to accomplish the task, you should use the following:
Primary key: A table usually has a column or combination of columns whose values uniquely identify each row in the table. This column (or columns) is called the primary key. Primary key ensures that no duplicate or null values are entered in the column (or columns) defined as primary key columns. This enforces integrity of the table. A primary key can be created by defining a primary key constraint while creating or altering a table. A table can have only one primary key constraint. As primary key constraints ensure uniqueness, they are often defined by using an identity column. Foreign key: A foreign key is a column or combination of columns used to establish and enforce a relationship between the data in two tables. This relationship is created by adding a column(s) in one of the tables to refer to the other table's column(s) protected by a PRIMARY KEY or UNIQUE constraint. This column becomes a foreign key in the first table. A
foreign key can be created by defining a FOREIGN KEY constraint when creating or altering a table. Answer: A is incorrect. Entity integrity enforces the uniqueness of rows in a table. The uniqueness of rows can be enforced by the identifier column(s) through indexes, UNIQUE constraints, PRIMARY KEY constraints, or IDENTITY properties.

Answer: B is incorrect. Domain integrity enforces data validity by restricting the data type, valid values (using CHECK constraints and rules), and range of possible values (using FOREIGN KEY constraints) for columns in a table.

QUESTION 8
You work as a Database Designer for Tech Perfect Inc. The company has a Windows Vista computer on which Microsoft Office 2010 is installed. The computer has a database named Sales created in MS Access 2010. You do not want to lose valuable data even when your computer encounters a problem. In order to save the data, you have to make backup copies of your database on a regular basis. Choose and re-order the steps that you will take to accomplish the task.

Answer:

```
Steps
Select the Save Database As option.
Click the Back Up Database option.
Choose a location for the backup copy.
Click the Save & Publish button.
Specify a backup name.
Click the Save button.
Click the File tab.
```

```
Answer:

Steps
Select the Save Database As option.
Click the Save & Publish button.
Specify a backup name.
Click the Save button.
```

```
Explanation:
Take the following steps to back up an Access database:
1. Save and close all objects in the database.
2. Click the File tab and then click the Save & Publish button.
```
3. Select the Save Database As option.

4. Click the Back Up Database option and then click the Save As button.
QUESTION 9
You work as a Database Designer for Tech Perfect Inc. The company has a Windows Vista-based computer with Microsoft Office 2010 installed on it. The computer has a database named Customers created in Microsoft Office Access 2010. You want to find all customer records where the contact person's title is Owner and the person is located either in Portland or in Eugene. Which of the following filter features will you use to accomplish the task?

A. Filter By Selection
B. Filter By Record
C. Advanced Filter
D. Filter By Form

Answer: D
Explanation:
In order to accomplish the task, you should use the Filter By Form feature. The Filter by Form feature is used to filter records based on the values in fields of a table, query, or form. It displays a filtering datasheet with blank fields. Each blank field is a combo box that contains a list of all the entries made in those fields. A user can select a value from this list or enter a new value. It is easy to use the Filter by Form feature when a table contains only a few fields. Answer: A is incorrect. The Filter by Selection feature is used to filter records based on the current selection in a field. Answer: C is incorrect. The Advanced Filter feature is used to create a simple query on a single table. Answer: B is incorrect. There is no such feature as Filter by Record in Access 2010.

QUESTION 10
You work as a Database Designer for Tech Perfect Inc. The company has a Windows Vista-based computer with Microsoft Office 2010 installed on it. You want to ensure that the databases created
in Microsoft Office Access 2010 save in the Microsoft Access 2003 format. Which of the following options will you choose in the Access Options dialog box to accomplish the task?

A. General  
B. Object Designers  
C. Client Settings  
D. Current Database

Answer: A

Explanation:
In order to accomplish the task, you will choose the General option in the Access Options dialog box. This option opens a page that includes the Default file format drop-down list as shown in the image given below:

You can change the format of any of the previous versions of Microsoft Access. Answer: D is incorrect. The Current Database option includes the settings for the currently used database.
QUESTION 11
Which of the following properties binds the forms and reports to a source from which data is to be retrieved?

A. RecordSource
B. ControlSource
C. Can Grow
D. RowSource

Answer: A

Explanation:
The RecordSource property belongs to the form and report objects. This property binds the object to a source from which data is to be retrieved. This source can be a table or a query. When a form or a report is bound to a table or a query, the controls can be bound to a column of the table through the ControlSource property.

Answer: C is incorrect. The Can Grow property allows a control to adjust its dimensions according to the contents present in the control. A control grows vertically to adjust its contents so that all the contents can be displayed. The default value of the Can Grow property is false. Answer: B is incorrect. The ControlSource property bounds a control to a field of a table. If a control is bound to a field by using this property, the control is known as a bound control. If the value of this property is blank, the control is known as an unbound control. If the ControlSource property contains an expression, the control is known as a calculated control. Answer: D is incorrect. The RowSource property belongs to the combo box and list box controls. When these controls are bound to a column by the RowSource property, all the data of the column is displayed in the list box or the combo box.
QUESTION 12
You work as a Database Designer for Tech Perfect Inc. The company has a Windows Vista-based computer with Microsoft Office 2010 installed on it. The computer contains two databases named Shippers and Orders created in Microsoft Office Access 2010. A one-to-many relationship is created between both tables. You want to delete a Shipper. The shipper that you want to delete has orders in the Orders table. When you delete the Shipper record, these orders will become "orphans". The orders will still include a shipper ID, but this ID will not be valid. What will you do to prevent these orphans?

A. Cascade delete related records.
B. Enforce domain integrity.
C. Cascade update related fields.
D. Enforce referential integrity.

Answer: D
Explanation:
To prevent these orphans, you should enforce referential integrity. Referential integrity means that the foreign key in any referencing table must always refer to a valid row in the referenced table. Referential integrity ensures that the relationship between two tables remains synchronized during updates and deletes. For a foreign key to be valid, it must contain either the value NULL, or an existing key value from the primary or unique key columns referenced by the foreign key. To enforce referential integrity, a foreign key column link to the primary key column should be created in the related table.

Answer: C is incorrect. You can cascade update related fields to update all affected rows as part of a single operation.
Answer: B is incorrect. Domain integrity enforces data validity by restricting the data type, valid values (using CHECK constraints and rules), and range of possible values (using FOREIGN KEY constraints) for columns in a table.
Answer: A is incorrect. You can cascade delete related records to delete a row and all related records.